ConnectCarolina: Links/Buttons Not Working in Chrome

This article provides steps to resolve the issue of links and buttons not working when accessing ConnectCarolina via Chrome.

 

Issue

Users are experiencing issues with ConnectCarolina (using Chrome) and receiving the below error or links/buttons not working.

  • Some users have experienced issues when clicking buttons or links on ConnectCarolina pages.
  • Some users receiving the message would say something along the lines of either "a frame has been blocked" or have the words cross-origins.

Cause

This is a result of security enhancements associated with Chrome updates.

Solution

To help resolve this issue you will need to do the followings:

 

Remove or Update Favorites/Bookmarks

If you are using favorites/bookmarks, please make sure to remove these. The best way to access ConnectCarolina is by going to the https://connectcarolina.unc.edu landing page.  If you need to bookmark this then please make sure to set the address as https://connectcarolina.unc.edu

 

Update Chrome

Google has released a recent upgrade of the Chrome browser.  To make sure that it has been completely upgraded you have to relaunch Chrome after the upgrade.

To check your version of Chrome please do the following:

  1. At the top right, click the 3 dots
  2. Click on Settings
  3. Click on About Chrome
  • If Chrome has an update it will show on this page and if you need to relaunch Chrome to finish the update you will see a Relaunch button.

 

Clear Chrome Cache and Cookies

  1. Select the 3 dots on the upper-right corner of your Chrome browser → select History → select History

 

  1. Select Clear browsing data

 

  1. On the new window - Select the Advanced tab → select All time → Check all the boxes except Passwords and other sign-in data if you want to keep your saved passwords. → Click Clear data.

 

  1. Close every tab and window of Chrome.
  2. Open Chrome and go to ConnectCarolina

 

Sign Out from Google Account

If you are using Chrome and signing in with a Google account.  We have seen where this has caused the error message to pop up on a more frequent basis.  Once the users have signed out or have used another profile in Chrome that is not signed in to a Google account the error has pretty much gone away.  Please visit this article called Use Chrome with multiple profiles.


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Details

Article ID: 209
Created
Wed 6/19/24 9:50 PM
Modified
Wed 6/19/24 10:44 PM